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1 INTRODUCTION 

Robot System Products is a front-rank provider of peripheral products for high performance 
robot applications. We provide complete tool systems solutions for your robot installations, 
aiming to improve your productivity with the most reliable and cost-effective tooling on the 
market. Continuously we explore emerging technologies, working with leading edge design. 

Robot System Products has a wide range of standard robot peripheral products: 

• Tool changers 

• Swivels 

• Swivel tool changers 

• CiRo  

• Grippers 

• Hose Packages 

• Valve units 

• Tool systems 

• Tool stands 

 

Robot System Products’ tool changers are constructed to maximize the flexibility and reliability 
of your robot fleet. Through our patented locking device TrueConnect™ robustness and high 
safety are combined with low weight and compactness. With our swivels compressed air, water, 
electrical and data signals as well as weld and servo power are transferred to your tools with 
robot motion capabilities fully maintained. Our Swivel tool changers unite the TrueConnect™ 
mechanism with our swivel technology, combining the best out of the two technologies. With 
RSPs unique CiRo, cables and hoses can be freely selected with high robot flexibility 
maintained, and the space requirements reduced. Our integrated Tool systems are delivered as 
complete plug-and-play solutions designed for quick and simple installation.  

Robot System Products’ product lines are available for all major robot brands and come with 
complete documentation. 3D-models for simulation are available for download at: 
www.rsp.eu.com 

1.1 RobotStudio add-in installation guide 

This document describes how the Robot System Products’ Tool systems are installed in 
RobotStudio®. RobotStudio is a tool for off-line programming of ABB robots, allowing robot 
programming to be done without shutting down production. RobotStudio is built on the ABB 
VirtualController and is an exact copy of the real software that runs the ABB robots in production. 
It allows tasks as training, programming, and optimization without disturbing production.  

Robot System Products’ Tool systems are described in the following documents: 

o Technical description Tool system TS20/10 for ABB IRB (M0114-1) 

o Technical description Tool system TS100/80 for ABB IRB (M0411-1) 

o Technical description Tool system TS250/200 for ABB IRB (M0721-1) 

This document is aimed for users knowledgeable in RobotStudio. The RSP add-in (section 2.1) 
is verified on versions 19.3 and 20.1. For general information on RobotStudio see Operating 
manual RobotStudio available through ABB.  

 

http://www.rsp.eu.com/
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2 INSTALLATION 

2.1 Installing RSP RobotStudio Add-in using RobotApps 

 Action Note 

1 Open RobotStudio - 

2 Add-ins tab 

 

Click the Add-ins tab located on 

the top of the window.  

 

NOTE! Installation of 

an Add-in shall only be 

done once. 

3 Install package 

 

Inside the RobotApps window, 

use the search function and type 

Robot System Products 

4 Select Add-in 

 

Navigate to and click on the RSP 

Tool Systems Add-in.  

5 Start installation 

 

Locate the RSP Tool Systems 

Information box on the right side. 

Make sure the latest version is 

chosen and click the Add button. 

 

Accept the Disclaimer. 

 

Wait for installation. 

6 Installation completed 

 

 

Once the installation is complete 

a confirmation message will be 

displayed in the bottom left. 

7 Restart RobotStudio 

 

Restart RobotStudio for the 

changes to take effect. 

8 Ready for import 

 

The contents of the installed 

Add-in can now be imported (see 

section 3). 
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2.2 Installing RSP RobotStudio Add-in manually 

 Action Note 

1 Open RobotStudio - 

2 Add-ins tab 

 

Click the Add-ins tab located on 

the top of the window.  

 

NOTE! Installation of 

an Add-in shall only be 

done once. 

3 Install package 

 

Click the Install Package button 

on the Add-ins tab. 

4 Select Add-in 

 

Navigate to the desired Add-in 

file (.rspak) and open. 

 

NOTE! The file filter 

may need to be 

selected as All 

supported file types or 

Package files.  

5 Wait for installation 

 

The Add-in will now be installed. 

The message Downloading 

package will be displayed in the 

bottom left corner. Please wait 

for the installation to finish. 

6 Installation completed 

 

 

Once the installation is complete 

a confirmation message will be 

displayed in the bottom left. 

7 Restart RobotStudio 

 

Restart RobotStudio for the 

changes to take effect. 

8 Ready for import 

 

The contents of the installed 

Add-in can now be imported (see 

section 2.2 and 3.1). 
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2.3 Updating to new version 

 Action Note 

1 Check for latest version You can always find information 

about the latest version of the 

RSP Tool Systems Add-in on our 

website: 

www.robotsystemproducts.com/r

obotstudio 

 

Check for the latest version 

before proceeding with the 

update procedure 

2 Secure old versions of RobotStudio models 

 

When importing a model from the 

add-in it is automatically 

connected to the add-in. To 

make sure the models are kept 

inside your station it is of 

importance that you break the 

connection to the add-in. 

 

This procedure is described in 

section 3, when importing 

models. 

 

IMPORTANT! Make 

sure that your stations 

are saved after 

disconnecting the 

library. This action has to be 

performed on each station. 

3 Add-ins tab Click the Add-ins tab located on 

the top of the window.  

4 Uninstall old version 

 

Locate the Robot Studio 

Products – Tool Systems Add-in, 

right click and select Uninstall 

Package. 

 

Once uninstall is completed a 

confirmation message will be 

displayed in the bottom left. 

5 Install new version Install the new version of the 

RSP Tool Systems Add-in 

according to section 2.1 or 2.2 in 

this manual. 

  

http://www.robotsystemproducts.com/


 M0726-1 version 3.2   9 

3. USER GUIDE 

3.1 Importing a robot with complete Tool System 

 Action Note 

1 Import Tool System 

 

Import a tool system using Import 

Library on the Home tab. 

3 Select robot model and Tool System 

 

Select the desired robot model, 

and model size using the 

dropdown menu. 

 

Select the type of Tool System, 

Swivel (S), Swivel Tool Changer 

(STC) or CiRo 

 

NOTE! When unit is 

selected the features, 

air ducts and/or 

electrical signals are 

displayed under the dropdown 

menu 

4 Disconnect library 

 

IMPORTANT! To make sure the 

complete robot is saved inside 

your station, you must break the 

connection to the Tool Systems 

Add-in. 

 

Right click on the robot model 

inside the Layout tab and select 

Disconnect Library 
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3.2 Importing a Tool adapter for CiRo 

 Action Note 

1 Import tool system 

 

 

Import a tool system using Import 

Library on the Home tab. 

 

If CiRo is used and ISO-interface 

is required, a Tool adapter must 

be imported. Otherwise go to 3.3. 

2 Connect a controller (optional) 

 

If required, connect a controller to 

the robot (see section 3.4). 

3 Import a CiRo Tool adapter

 

 

Import a CiRo Tool adapter using 

Import Library on the Home tab.  

4 Install the tool adapter  

 

Install the tool on the tool system 

using drag and drop on the 

Layout tab. 

 

Click “Yes” to update the position. 

 

NOTE! The procedure 

is described in 

Operating manual 

RobotStudio. 

4 Disconnect library 

 

IMPORTANT! To make sure the 

Tool adapter is saved inside your 

station, you must break the 

connection to the Tool Systems 

Add-in. 

 

Right click on the Tool adapter 

inside the Layout tab and select 

Disconnect Library 
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3.3 Adding a tool on Swivel/CiRo 

 Action Note 

1 Import tool system A tool system with Swivel (S) or 

CiRo must have been imported 

(see section 3.1). 

 

If CiRo is used and ISO-interface 

is required, a Tool adapter must 

be imported (see section 3.2). 

2 Import or Create a tool

 

 

Import a tool using Import Library 

on the Home tab.  

3 Install the tool  

 

Install the tool on the tool system 

using drag and drop on the 

Layout tab. 

 

NOTE! The procedure 

is described in 

Operating manual 

RobotStudio. 

4 Select the Offset tab 

 

 

Select and open the Offset 

Position tab by right clicking on 

the tool on the Layout tab.  
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5  Offset the tool 

 

 

Select Local as reference system 

and add an offset in the +Z-

direction. (See table 6.1). Click 

Apply. 

 

NOTE! Offsets from the 

robot flange are 

available in the 

Technical description of 

respective tool system in the 

section Robot programming data. 

6 Create new tooldata 

 

 

Create new tooldata using 

Other → Create Tooldata in the 

Home tab and click Create. 

 

The tool is now installed 
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3.4 Connecting a virtual controller to RSP tool system 

 Action Note 

1 Import tool system A tool system must have been 

imported (see section 3.1). 

2 Add a controller 

 

Add a new virtual controller using 

Virtual Controller → New 

controller on the Home tab. 

3 Select robot model 

 

 

Select the same robot model as 

in the tool system. Once the 

correct robot model is selected, 

press OK.  

 

NOTE! The robot 

model is specified in 

the default library name 

of the tool system. 

4 Select library from station 

 

 

 

In the process of creating the 

virtual controller, the window 

Select library will appear. 

 

Select the library (a tool system 

with robot) from the station using 

the dropdown menu. Press OK to 

continue. 

5 The virtual controller is now connected. 

 

A confirmation message will be 

displayed in the bottom left. 
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4 TOOL CHANGE FUNCTION 

4.1 Adding a Tool attachment for Swivel with tool changer 

 Action Note 

1 Import tool system A tool system must have been 

imported (see section 3.1). 

 

NOTE! To be able to 

use the tool changing 

function, a Tool System 

with (STC) Swivel Tool 

Changer must be imported. 

3 Import a Tool attachment

 

 

Import a Tool aattachment using 

Import Library on the Home tab.  

 

NOTE! Selectable tool 

attachments are 

described in the 

Technical description 

of respective tool 

system in the section 

Specification of parts and 

options. 

4 Position the Tool attachment 

 

Position the Tool attachment to 

the desired coordinates. 

 

NOTE! The procedure 

is described in 

Operating manual 

RobotStudio. 

4 Disconnect library 

 

IMPORTANT! To make sure the 

Tool attachment is saved inside 

your station, you must break the 

connection to the Tool Systems 

Add-in. 

 

Right click on the Tool adapter 

inside the Layout tab and select 

Disconnect Library 
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4.2 Adding a tool to the Tool attachment 

 Action Note 

1 Import tool attachment Import a tool attachment using 

Import Library in the Home tab. 

(see section 4.1). 

2 Create or import a tool 

 

Import a tool using Import Library 

on the Home tab. 

3 Install the tool 

 

 

Install the tool on the Tool 

attachment using drag and drop 

in the Layout tab. 

 

NOTE! The procedure 

is described in 

Operating manual 

RobotStudio. 

5 Select the Offset tab 

 

Select and open the Offset 

Position tab by right clicking on 

the tool on the Layout tab.  

 

 

4  Offset the tool 

  

Select Local as reference system 

and add an offset in +Z-direction. 

(This offset is the same as the 

thickness of the tool attachment). 

Click Apply. 

 

NOTE! Offsets of the 

tool attachments are 

available in the 

Technical description of 

respective tool system in the 

section Specification of parts and 

options. 

5 The tool is now installed on the Tool attachment  
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4.3 Docking the tool attachment to the tool changer 

 Action Note 

1 Import needed libraries Ensure that the libraries, where 

required tool changer and tool 

attachment, are available and 

imported. 

2 Attach tool to tool attachment (optional) See section 4.2 Adding a tool to the 

Tool attachment. 

3  Check simulation setup 

 

  

NOTE! The simulation must be 

running for tool changer components 

to function properly. 

 

IMPORTANT! If the robot is 

connected to a program it 

must be deactivated inside 

simulation setup to prevent 

the robot program from running. 

 

Open Simulation setup inside the 

Simulation tab. Uncheck the box 

under Simulate for the robot. 

4  Start simulation 

 

Start the simulation. 

 

5 Open tool changer properties 

 

Open Properties for the tool changer 

by right clicking on the tool system on 

the Layout tab. 

6 Open the tool changer 

 

Make sure the tool changer is in open 

state before docking the tool 

attachment. The tool changer can be 

controlled using one or two input 

signals, depending on TC model.  

 

NOTE! The simulation will be 

halted, and an error 

message displayed when the 

distance between a tool 

attachment and a tool changer in 

closed state becomes short. 

To continue, make sure that the tool 

changer is opened and restart the 

simulation 
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7 Move robot to docking position 

 

 

Move the robot to docking position. 

Ensure that the tool attachment is 

correctly orientated and positioned as 

close as possible to the tool changer. 

Most tool changers and tool 

attachments have indicators to show 

proper docking orientation.  

 

NOTE! The model of the tool 

changer cannot identify that 

a tool attachment is 

incorrectly orientated. 

8 Close the tool changer 

 

 

Close the tool changer by changing 

the status of the input signal or signals 

(DoOpen) to low. The tool attachment 

is now attached to the tool changer. 

 

NOTE! When correctly docked the 

signals TC_Uncoupled will be low and 

TA_Coupled will be high. STC20 does 

not support TC_Uncoupled. STC 

without electrical signals (E) does not 

support TC_Uncoupled or 

TA_Coupled. 

9 Create new tooldata 

 

 

 

 

Create new tooldata for the 

combination tool changer + tool 

attachment + tool using Other → 

Create Tooldata in the Home tab and 

click Create. 
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5. TOOL STAND KIT 

5.1 Import Tool Stand kit for TA20 

 Action Note 

1 Import needed libraries Ensure that the libraries, where 

required robot, tool changer and tool 

attachment, are available and 

imported. 

2 Import Tool stand kit 

 

Import a Tool stand kit using Import 

Library on the Home tab 

3  Select Tool stand kit part 1 

 

  

Select the Tool stand kit (Part 1/2) and 

click OK. 

 

Position the Tool stand kit to the 

desired coordinates 

 

NOTE! For TA20 you must 

load two different parts. 

Part 1 which is the Tool 

Stand kit and part 2 which 

is to be mounted on the Tool 

attachment.  

4 Select Tool stand kit part 2 Select the Tool stand kit (Part 2/2) and 

click OK. 

5 Install part 2 to Tool attachment 

 

Install the Tool stand kit part 2 on the 

Tool attachment using drag and drop 

in the Layout tab. 
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5.2 Import Tool Stand kit for TA100 and TA250 

 Action Note 

1 Import needed libraries Ensure that the libraries, where 

required robot, tool changer and tool 

attachment, are available and 

imported. 

2 Import Tool stand kit 

 

Import a Tool stand kit using Import 

Library on the Home tab 

3  Select desired Tool stand kit 

 

  

Select the desired Tool stand kit and 

click OK. 

4 Position the Tool stand kit Position the Tool stand kit to the 

desired coordinates. 

 

NOTE! The procedure is 

described in Operating 

manual RobotStudio.  
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6. APPENDIX 

6.1 Offset table for tool data 

Robot 

model 

(art.no 

prefix) 

Functionality 

(art.no suffix) 
Weight 

Centre of 

gravity (Z-

direction) 

Offset 

(Z-

direction) 

Tool 

Attachment 

thickness 

IRB140 

(TS101) 

S20-2 (-203) 0.5 kg 13 mm 36.6 mm - 

S20-2E (-204) 0.8 kg 20 mm 48.5 mm - 

CiRo S2 (-211) 1.3 kg 25 mm 58 mm - 

CiRo S2 (-211) with option 

P5305 
1.5 kg 32 mm 98 mm - 

      

IRB1600 

(TS102) 

S20-2 (-203) 0.5 kg 13 mm 36.6 mm - 

S20-2E (-204) 0.8 kg 20 mm 48.5 mm - 

CiRo S2 (-211) 1.3 kg 25 mm 58 mm - 

CiRo S2 (-211) with option 

P5305 
1.5 kg 32 mm 98 mm - 

      

IRB 1300 

(TS103) 

S20-2 (-201) with P0102 

(TA20-4) 
1.1 kg 36 mm 81.7 mm 16 mm 

S20-2 (-201) with P0123 

(TA20-4, Steel) 
1.3 kg 42 mm 81.7 mm 16 mm 

STC20-4E (-202) with P0109 

(STA20-4E) 
1.5 kg 39 mm 93.6 mm 16 mm 

STC20-4E (-202) with P0125 

(STA20-4E, Steel) 
1.7 kg 44 mm 93.6 mm 16 mm 

S20-2 (-203) 0.6 kg 11 mm 36.6 mm - 

S20-2E (-204) 1.0 kg 18 mm 48.5 mm - 

S20-6 (-205) 0.9 kg 26 mm 68.6 mm - 

S20-6E (-206) 1.3 kg 30 mm 80.5 mm - 

CiRo S1 (-211) 1.3 kg 23 mm 58 mm - 

CiRo S1 (-211) with option 

P5305 
1.5 kg 31 mm 98 mm - 

      

IRB2600 

(TS104) 

STC20-4 (-201) with P0102 

(TA20-4) 
1.3 kg 41 mm  97.3 mm 16 mm 

STC20-4 (-201) with P0123 

(TA20-4, Steel) 
1.5 kg 47 mm 97.3 mm 16 mm 

STC20-4E (-202) with P0109 

(STA20-4E) 
1.6 kg 45 mm 105.6 mm 16 mm 

STC20-4E (-202) with P0125 

(STA20-4E, Steel) 
1.8 kg 51 mm 105.6 mm 16 mm 

S20-2 (-203) 0.8 kg 17 mm 48.6 mm - 

S20-2E (-204) 1.1 kg 24 mm 60.5 mm - 

S20-6 (-205) 1.1 kg 30 mm 80.6 mm - 

S20-6E (-206) 1.4 kg 36 mm 92.5 mm - 

CiRo S1 (-211) 1.3 kg 24 mm  58 mm - 

CiRo S1 (-211) with option 

P5305 
1.5 kg 32 mm 98 mm - 
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Robot 

model 

(art.no 

prefix) 

Functionality 

(art.no suffix) 

Weight Centre of 

gravity (Z-

direction) 

Offset 

(Z-

direction) 

Tool 

Attachment 

thickness 

IRB4600-

20/2,5 

(TS106) 

STC20-4 (-201) with P0102 

(TA20-4) 
1.3 kg 41 mm  97.3 mm 16 mm 

STC20-4 (-201) with P0123 

(TA20-4, Steel) 
1.5 kg 47 mm 97.3 mm 16 mm 

STC20-4E (-202) with P0109 

(STA20-4E) 
1.6 kg 45 mm 105.6 mm 16 mm 

STC20-4E (-202) with P0125 

(STA20-4E, Steel) 
1.8 kg 51 mm 105.6 mm 16 mm 

S20-2 (-203) 0.8 kg 17 mm 48.6 mm - 

S20-2E (-204) 1.1 kg 24 mm 60.5 mm - 

S20-6 (-205) 1.1 kg 30 mm 80.6 mm - 

S20-6E (-206) 1.4 kg 36 mm 92.5 mm - 

CiRo S1 (-211) 1.3 kg 24 mm  58 mm - 

CiRo S1 (-211) with option 

P5305 
1.5 kg 32 mm 98 mm - 

      

IRB4600-

40 

(TS131) 

STC100-2E (-402) with 

P0409/P0418 

7.5 kg 50 mm 111 mm 28 mm 

STC100-2E (-402) with 

P0404/P0474 

8.2 kg 55 mm 127 mm 44mm 

STC100-6E (-404) with 

P0409/P0418 

8.4 kg  66 mm 140 mm 28 mm 

STC100-6E (-404) with 

P0404/P0474 

9.2 kg 71 mm 156 mm 44mm 

S100-4E (-406) 5.5 kg 34 mm 105 mm - 

S100-8E (-408) 6 kg 47 mm 134 mm - 

CiRo MHD1 (-411) 6 kg  37 mm 95 mm - 

CiRo MHD1 (-411) with 

P5205 

7 kg 52 mm 170 mm - 

      

IRB4600-

45/60 

(TS132) 

STC100-2E (-402) with 

P0409/P0418 

7.5 kg 50 mm 111 mm 28 mm 

STC100-2E (-402) with 

P0404/P0474 

8.2 kg 55 mm 127 mm 44mm 

STC100-6E (-404) with 

P0409/P0418 

8.4 kg  66 mm 140 mm 28 mm 

STC100-6E (-404) with 

P0404/P0474 

9.2 kg 71 mm 156 mm 44mm 

S100-4E (-406) 5.5 kg 34 mm 105 mm - 

S100-8E (-408) 6 kg 47 mm 134 mm - 

CiRo MHD1 (-411) 6 kg  37 mm 95 mm - 

CiRo MHD1 (-411) with 

P5205 

7 kg 52 mm 170 mm - 
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Robot 

model 

(art.no 

prefix) 

Functionality 

(art.no suffix) 
Weight 

Centre of 

gravity (Z-

direction) 

Offset 

(Z-

direction) 

Tool 

Attachment 

thickness 

IRB4600-

40 

(TS131) 

STC100-2E (-402) with 

P0409/P0418 

7.5 kg 50 mm 111 mm 28 mm 

STC100-2E (-402) with 

P0404/P0474 

8.2 kg 55 mm 127 mm 44mm 

STC100-6E (-404) with 

P0409/P0418 

8.4 kg  66 mm 140 mm 28 mm 

STC100-6E (-404) with 

P0404/P0474 

9.2 kg 71 mm 156 mm 44mm 

     

      

IRB6700 

Higher 

line 

(TS152, 

TS152L) 

STC250-6E (-602) with 

P6431/P6418 

22.4 kg 91 mm 209 mm 35 mm 

STC250-6E (-602) with 

P6473 

23.5 kg 96 mm 219 mm 45 mm 

S250-8E (-604) 17.4 kg 66 mm 192 mm - 

CiRo XL1 (-611) with P5501 18.8 kg 56 mm 120 mm - 

CiRo XL1 (-611) with P5501 21.7 kg 69 mm 175 mm - 

STC250-6E (-602) with 

P6431/P6418 

22.4 kg 91 mm 209 mm 35 mm 

      

IRB6700 

Power 

line 

(TS153,  

TS153L) 

STC250-6E (-602) with 

P6431/P6418 

23.4 kg 86 mm 209 mm 35 mm 

STC250-6E (-602) with 

P6473 

24.4 kg 91 mm 219 mm 45 mm 

S250-8E (-604) 18.3 kg 61 mm 192 mm - 

CiRo XL1 (-611) with P5501 18.8 kg 56 mm 120 mm - 

CiRo XL1 (-611) with P5501 21.7 kg 69 mm 175 mm - 
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